Issues with Integrating the Android SDK

Solved!
Posted in Android by Shai Katz Tue Apr 04 2017 12:20:05 GMT+0000 (UTC)·3·Viewed 161 times

Hi, Trying to walk through the Android SDK integration guide, I see those dependencies: compile 'com.squareup.dagger:dagger:1.2.2' compile 'com.squareup.dagger:dagger-compiler:1.2.2' My app already using dagger V2, and it cannot have both. How can I solve that issue?
Mike Smales
Apr 5, 2017

Hi Shai,

Thanks for getting in touch.

As far as I understand, dagger V1 and dagger V2 should be compatible with each other as they use a different package name.

I am assuming that you are using the following package?

compile 'com.google.dagger:dagger:2.x'

Do let me know if that is not the case.

Thanks,

Mike

Mike Smales
June 8, 2017

For anyone else coming across this post, dagger V1 or dagger V2 is no longer required as a dependency in the Android SDK (v2.5.1 onwards).


Mike Smales marked this as solved
Markdown is allowed